Problem z backupem na Windows Server 2012

Autor wpisu
michal-avatar-dreamiteamMichał Ruta
Czas potrzebny na przeczytanie
5 minut

winserwWyobraźcie sobie następującą sytuację: instalujecie serwer, ustawiacie polityki bezpieczeństwa, instalujecie oprogramowanie, konfigurujecie wszystko wiele godzin wraz ze stacjami roboczymi.

Na koniec konfigurujecie backup na serwerze i sprawdzacie go przed ostatecznym oddaniem infrastruktury klientowi.

Jakiś czas później wykonujecie prace dodatkowe: instalacja SharePoint Servera, aktualizacja, instalacja Visual Studio, dot.net i kilku innych potrzebnych rzeczy.

Jak każdy szanujący się administrator, InfoMagicy z DreamITeam wykonują okresowe sprawdzanie backupów oraz wymianę dysków USB u naszych klientów: dwa dyski, z czego jeden jest zawsze poza firmą, to najlepszy sposób zapewnienia niemal 100% bezpieczeństwa danych.

Nagle okazuje się, że backup…. w ogóle nie działa!

Wykonaliśmy standardowo:

zatrzymanie i uruchomienie ponowne usługi – nie pomogło,

restart serwera – nie pomogło,

ponownie utworzenie harmonogramu backupu – nie pomogło,

odszyfrowaliśmy dyski – nie pomogło,

odinstalowaliśmy funkcję serwera backupu i zainstalowaliśmy ponownie – nie pomogło,

ponownie sformatowaliśmy dyski – nie pomogło,

sprawdziliśmy usługę kopii w tle – nie zgłaszała błędów.

Ostatnią deską ratunku okazała się baza wiedzy Microsoft…

Odnaleźliśmy poprawkę, dzięki której problem został rozwiązany – co ciekawe, poprawka występuje jako kompatybilna z systemem Windows Server 2008, ale uwaga – działa prawidłowo pod Windows Server 2012- sprawdziliśmy, wszystko jest jak należy.

Okazało się, że backup nie obejmuje (przed poprawką) folderów, które przekraczają 1000 podfolderów. Taka sytuacja natomiast ma miejsce przy zainstalowanym SharePoint lub Visual Studio. W katalogu Microsoft.Net znajduje się ponad 1000 podkatalogów. Ta poprawka eliminuje ten błąd i zapewnia poprawne wykonanie kopii zapasowych.

Tu jest link do artykułu w bazie Microsoft: http://support.microsoft.com/kb/2807849/pl

Oczywiście harmonogram trzeba było ustawić od nowa, ale backup ruszył i działa bez problemów.

Ehh.. i niech ktoś mi powie, że informatycy generalnie nic nie robią..